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Before you start . ..

About This Documentation

This documentation applies to the installation of the software "Prinect Package Designer" as of 
Mediaset version 21.10.30 or as of Cloud Ready version 55.0.4. 

What You Should Already Know

We assume that you are familiar with the basic functions of Windows ®/Apple® Macintosh® in a net-
work environment. 

Typographical Conventions

The following typographical conventions are used in this manual:

• References to other chapters and sections are blue (on the screen) and underlined.

Example: See "Typographical Conventions", page 5.

• Quotes are used to indicate menus, folders, names of functions, hardware conditions, switch 
settings, system messages, etc.

Example: Set the switch to "off".

• Menus, functions and sub-functions are separated by ">".

Example: Select "File > Open...". 

• Keys which you should hold down simultaneously are connected with a plus character.

Example: Press "Alt + A".
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Installation

Prerequisites in the Prinect Environment

The following hardware and software prerequisites must be met:

Online Help > Prinect Know How > Newsroom & Release Notes > Prinect System Technology. 

Installation

You need administrator permissions for the computer you want to install Prinect Package Designers 
on. 

1. Folders "HDEnvironment" and "ServiceTools" as well as "PackagingSuiteSetup,exe" must be 
present in your installation folder. 

Click "PackagingSuiteSetup,exe" to start installation.

2. Confirm the license query with "Yes".

https://onlinehelp.prinect-lounge.com/App/App_news/en/index.htm#t=Prinect%2Fsystech%2Fsystech-1.htm
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3. Select the desired type of installation:
The option "Local Installation" is intended for a standard installation of the Prinect Package 
Designer.
The option "Server installation" with the "Prinect Package Designer Server" option enabled is 
intended for an integrated Prinect workflow (refer to section "Prinect Package Designer Server", 
page 24).
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4. The Production Manager license always comprises the Synergy configuration. You can addition-
ally purchase the Diemaker license and choose the configurations according to the purchased 
licenses as follows:

• [1] "Prinect Package Designer + Synergy": This the standard package covered by the Production 
Manager license without Diemaker. 

• [2] "Prinect Package Designer & Diemaker + Synergy": This the standard package covered by the 
Production Manager license plus Diemaker. 

• [3] Adobe Illustrator plugin: 
The plugin is installed automatically if an Adobe Illustrator installation is found during installa-
tion.
If there is no Adobe Illustrator at the time of PPD installation, the plugin can be installed later 
once the Adobe product has been added.

The plugin for Adobe Illustrator can also be operated outside of your own network. In this case, 
choose option [3] and install the plugin. This requires that Adobe Illustrator is installed on the 
computer.
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5. [1] Choose the default language in which Prinect Package Designer is to start.

[2] Choose the default measurement units. 

[3] Click "Browse" to go to an alternative installation folder if desired. 
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6. [1] Choose the folder for your work environment. This is the default folder where all files created 
with Prinect Package Designer such as the *.evd files are saved. 

[2] If instances of Prinect Package Designer are running on several computers in your network, 
they can share the resources in a specified folder. Typically, this is a folder on the Production 
Manager Server. To specify a new folder where to copy the resources, choose "Set location and 
copy files". To use an existing folder, choose "Select existing settings folder" and navigate to the 
folder. 

[3] The same as in item [2] applies to library copying. Select the folder where you wish to save 
the standard library. 
To specify a new folder, choose "Set location and copy files". To use an existing folder, choose 
"Select existing libraries folder" and navigate to the folder. 



Installation

12 As of Version 2021.10 - CR 55.0.04

7. Select the CAM or CNC machine used in your company. 

To can specify it later; choose "Tools> CAM > Machines" in Prinect Package Designer. 
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8. For unrestricted use of the 3D function (display of special 3D effects), you need a powerful 
graphics card and the corresponding driver. 

During installation, a check is made to see if these requirements are met. If not, the following 
dialog displays:
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The following dialog displays if the requirements are met: 

Check the quality of the left image rendered with your settings by comparing it with reference 
image to the right. If not, you can click "No, try lower quality" and check if the comparison is 
more satisfactory at a lower resolution. You can repeat this a second time. If the result is then 
insufficient although the quality was reduced, the dialog mentioned above appears with the 
message that the graphics card is insufficient or that the appropriate driver is not available. 

Confirm with "Yes" if you are satisfied with the image comparison. 

9. If Adobe Illustrator is installed on your computer, you will be prompted to close it should it be 
running. 
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10. Select the file formats to be opened automatically with Prinect Package Designer when double-
clicked. 
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11. Choose the folder where the setup data for later updates is to be stored. 

[1] "Keep setup data in current location": If there is already setup data from a previous installa-
tion, the new setup data will be written to the same folder.

[2] "Copy setup data to system default location": The setup data is copied to the folder the sys-
tem offers by default. 

[3] "Copy setup data to custom location": If you choose this option, you can click "Browse" to 
go to the folder you want. 
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12. Option "Create desktop icons": Choose this option to place icons that you can use to start the 
program, for example, on the desktop. 

Terminate installation with "Finish". 
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The program executable is then located here in the file system: 



Installation

Prinect Package Designer – Installation 19

Prerequisites for running Prinect Package Designer 
The following prerequisites must be met to be able to run Prinect Package Designer after successful 
installation:

Licensing

1. Start Prinect Package Designer by clicking the "Package Designer" icon or via the Start menu:

2. Confirm the dialog with the license note.

3. Specify the computer name or the IP address of the License Server and select the configuration 
for which you purchased a license.
(The selected configuration will become available if the respectively required licenses were 
enabled in the License Server with the License Manager.)

Dies

You can also invoke this dialog with "Help" > "Register". Please restart Prinect Package Designer 
to make the changes take effect. 
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Integrated Workflow

To operate Prinect Package Designer in the integrated workflow, you must perform the steps 
described in section "Prinect Package Designer Server", page 24 in addition to licensing: 

• During installation, you chose the "Server Installation” with "Prinect Package Designer Server" 
option, which makes the "EVJDFDaemon" background service run on the Prinect Workflow 
Server. See "PPD background service "EVJDFDaemon" (interface PPD to PPM)", page 25

• Configure the JDF Server in the "System Configuration Utility". See "Configure JDF server for 
manual integrated workflow in the client "EngView System Configuration Utility"", page 27. 

• (Usually, you do not need to perform this step actively:) The background service "PD-Connect" 
must have been started on the Prinect Production Manager computer. See "PPM background 
service "PD Connect" (interface PPM to PPD)", page 26
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Modify, Repair or Remove Installation
Prerequisites for modifying, repairing or removing the installation are: an initial installation has been 
completed, and Prinect Package Designer has been terminated if it has been running.

1. There are two ways of starting the Assistant:

• Option 1: Invoke the Windows Start menu, open the folder "Heidelberg Prinect Package 
Designer" and click "Maintain Heidelberg Prinect Package Designer".

• Option 2: In the Windows Start menu, open Windows Settings, then "Apps". In "Apps and fea-
tures", select Prinect Package Designer and click "Uninstall". 

In both cases, the following uninstallation sequence starts. 

2. The following dialog displays only if you uninstall Prinect Package Designer Server. In this case, 
you would typically be working with an integrated workflow and one or more clients, see also 
"Integrated Workflow: Brief Overview", page 24 and "PPD background service "EVJDFDaemon" 
(interface PPD to PPM)", page 25. 
If you uninstall a server installation in this environment, the background service "EVJDFDae-
mon" will also be terminated, although requests from clients to this background service may still 
be in progress. Therefore, this dialog offers the following choices:

"Retry": Check if all client requests have been processed. If yes, stop the background service 
"EVJDFDaemon" manually in Task Manager and continue with the uninstallation afterwards.

"Ignore": If you select this option, the uninstaller will automatically terminate the background 
service "EVJDFDaemon", and any client requests that may be in progress will be canceled or no 
longer processed. 

"Cancel": This will terminate the uninstallation process. 
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3. Select a mode: 

[1] : "Modify": The "Modify" function has no effect here. 

[2] : "Repair": Installation will be repeated and any errors of the initial installation will be cor-
rected. The configuration will remain unchanged. 

[3] : "Remove": The program is uninstalled and completely removed from the computer. 

Choose "Remove" and click "Next".

[]
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4. This step is relevant only if multiple computers share folders for resources and the Standard 
Library. 
You can then decide to delete the resources and the Standard Library during uninstallation. If 
you are sharing resources and the Standard Library with other clients and they are still using 
them, you may typically want to keep them. 

Click “Next”. This will start the uninstallation process. 
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Prinect Package Designer Server 

Integrated Workflow: Brief Overview

You can install Prinect Package Designer as CAD server on the Production Manager server of a Prinect 
Integration system. This CAD server will then run in the background without dedicated user interface. 

In the integrated workflow, Prinect Production Manager (PPM) always sends jobs to Prinect Package 
Designer (PPD) where they are processed, and the results (contour or layout) are sent back to PPM. 

This is also the case in an extended workflow, i.e. with MIS import or if Prinect Business Manager 
(PBM) is involved. In this case, for example, the job is sent from PBM to PPM and from there to PPD. 
The result is returned on the same path, i.e. via PPM to PBM. 

As a rule, you have two options in the integrated workflow: You can have a job processed automati-
cally by the PPD server with preset parameters. This process runs completely in the background. 
However, you can also process a job manually on PPD. In this case, you must run PPD on the client 
manually, select the job from the job list, process it manually, and then return the result. The decision 
as to whether automatic or manual is made by setting the DesignCreation template in Prinect Cock-
pit. 
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PPD background service "EVJDFDaemon" (interface PPD to PPM) 

The interface to PPM is vital for PPD installation. On the PPD side, a background service must run 
during operation that receives the jobs (requests) from PPM and sends the results back to it. 
For this purpose, you must set the "Server Installation” with "Prinect Package Designer Server" option 
during installation. This will install and start the server function "EVJDFDaemon" [2] (visible in Task 
Manager > "Services" tab [1], see the screenshot below). 



Installation

26 As of Version 2021.10 - CR 55.0.04

PPM background service "PD Connect" (interface PPM to PPD)

On the PPM side, the background service "PD Connect" must be running; it sends requests to PPD 
and receives the results. This process runs in the background automatically. You can (re)start it via 
PMC if this is not the case as an exception: 

1. Go to the "Prinect Supervisor" [2] view in PMC [1]. 

2. Select the PPM server [3]. The list to the right shows the components running on this server.

3. Select the "PD Connect" [4] service.

4. Invoke the context menu and choose "Restart Component" [5]. 
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Configure JDF server for manual integrated workflow in the client "EngView System 
Configuration Utility"

This configuration is required for the manual integrated workflow because in this case PPD is invoked 
on the client and the JDF server and the data transmission channel via Port ID must be made known 
to the client. In the automatic workflow, data exchange between JDF server and the PPD server appli-
cation runs automatically in the background, and the address for data exchange is already known.

Thus, the JDF server name as well as the port ID must be made known to each client that is to be 
used for the manual integrated workflow. 

1. If PPD is running, you must terminate it first. 

2. In Windows Start menu, open "Heidelberg Prinect Package Designer" [1] and then "EngView Sys-
tem Configuration Utility" [2]. 

3. Go to the "EVPPD 21.10.... " tab [3]. 

4. Click next to "JDF Server" [4] and then "Browse" [5]. 
Type the JDF server name next to "Server IP" and Port ID "6091" next to "Server port". 

(Additional information: An entry for the MDS server is not required, as the background service 
"PD Connect" establishes the connection to MDS. The MDS connection is important for access 
to the materials and the PPD library entries. The PPD library entries located in the folder speci-
fied during installation are addressed via metadata in the MDS (IDs descriptions)).
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5. Confirm with "OK".
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